Austin Ten Drivers Club

Welcome to the Austin Ten Drivers Club Forums!

You are not logged in.

#1 2018-07-14 00:50:33

Dave Young (8215)
Guest

Fuel Pump

1932 Austin10
My original mechanical fuel pump was disconnected when I purchased the car a couple of years ago. It has an electric SU pump fitted. Problem is that it is unreliable and sometimes it will not draw fuel up from the tank, seems this is more the case in colder weather. Any suggestions? I was thinking I could try a more efficient electric pump. Does anyone else have similar issues. Not sure why the original pump was disconnected. I would prefer to keep it as original as possible. An option might be to connect the original pump.
Thank you
Dave Young

#2 2018-07-14 09:54:50

8617_Mr_Syd_Smith
Members
Registered: 2015-10-02
Posts: 316

Re: Fuel Pump

Dave, It was, and still is to some extent, a common practice to back up or replace the mechanical pump with an SU and leave the mechanical pump in place.

Both types have their problems, but both types can be made reliable.

Spares are available for the mechanical pump and an overhaul should restore it to good working order then you can remove the SU.

The contacts on the SU are the main problem and they will respond to cleaning, there are electronic replacements available for the pump which make it very reliable. Because they are often mounted on rubber to cut down noise a good earth is also often a problem.

Because different models of mechanical pump look very similar but are in small way different, it should be said that it is not uncommon to find the wrong pump has been fitted.

Often the difference is a small change to the length of the operating arm, if it is slightly short it does not make contact with the cam it operates from.

Ted Bellamy (George Bellamy on this forum) did some research on this subject last year, worth looking up his thread using the search button perhaps.   

Hope that helps  Syd

Offline

#3 2018-07-14 15:37:24

8565_Michael_Love
Members
Registered: 2015-07-30
Posts: 244

Re: Fuel Pump

Hi Dave,

I am with you, as original as possible. The mechanical pump should be just as reliable as anything else on the car when well maintained. It is worth stripping down and seeing what stopped the old one working, and checking, as Syd says that it is actually the right one. I have never had to strip mine yet, but having read a few posts it looks relatively easy and if you can get that working again, that is one less load on your electrics.

Please keep us updated on how it goes, and good luck. 

Mike

Offline

#4 2018-07-15 11:12:06

Dave Young (8215)
Guest

Re: Fuel Pump

Thank you Sid and Mike for your comments. The problem is now fixed. After referring to my old MGA workshop manual re the SU petrol pump and pulling the pump off I discovered that the pump had been installed upside down. This was the reason why the pump was struggling to suck and hold the fuel from the tank.

The fuel is now delivered efficiently and the Austin is starting and running better than ever.

Best wishes
Dave

#5 2018-07-15 20:06:46

8565_Michael_Love
Members
Registered: 2015-07-30
Posts: 244

Re: Fuel Pump

Goes to prove its worth doing the simple checks first then smile

Happy days.

Offline

#6 2018-07-16 12:32:43

8617_Mr_Syd_Smith
Members
Registered: 2015-10-02
Posts: 316

Re: Fuel Pump

Good to hear you have sorted it Dave.

Well worth joining the ATDC for lots more hints and help with your Austin, especially when it comes to spares and advice.

Offline

Board footer

Powered by FluxBB